Cenit Integrations Client install hint: dependencies
5 March, 2021 by
Cenit Integrations Client install hint: dependencies
Administrator

Cenit

For anyone who is trying to install the Cenit Integrations Client please know that it depends on the python packages inflect and requests[security]. Those must be installed before the Client.

Info about the inflect package is here: https://pypi.python.org/pypi/inflect.

Info about the requests[security] package is here: https://pypi.python.org/pypi/requests. There is a known dependecy issue when installing this, at least on Ubuntu 14.04. You have to make sure that your system has libffi6 and libffi-dev already installed. You can read about these issues here: http://stackoverflow.com/questions/29596426/how-to-pip-install-cairocffi or http://askubuntu.com/questions/499714/error-installing-scrapy-in-virtualenv-using-pip.

Cenit has a nice little screencast of how the setup works on YouTube. Find that here: https://www.youtube.com/watch?v=Xz7c1k0ZL_k.