Intermittent wired network issues in 14.04
5 March, 2021 by
Intermittent wired network issues in 14.04
Administrator

 

I’m not entirely sure why this worked, but it seems to have. It’s not an ideal solution, but at least it works.

What I did was that I removed the address reservation I had set in my router, and set IPv4 Settings → Method to “Automatic (DHCP)” instead of “Manual” (I had previously tried to set it manually, which “worked”, but didn’t resolve my issue). I also set IPv6 Settings → Method to “Ignore” just on a hunch.

After that, I restarted the resolveconf and network-manager services, but it didn’t seem to help. So I tried restarting the networking service, which failed. After googling a bit, it seems that’s not a supported way of restarting your network interfaces, so I restarted them manually instead:

sudo ifdown --exclude=lo -a && sudo ifup --exclude=lo -a

That seems to have done the trick. I’m not sure if the static IP assignment had anything to do with it, or if it was disabling IPv6, but either way, it works now.