DNS error Virtualmin LXC
5 March, 2021 by
DNS error Virtualmin LXC
| No comments yet

DNS Zone Error

Virtualmin is configured to setup DNS zones, but this system is not setup to use itself as a DNS server. Either add to the list of DNS servers, or turn off the BIND feature on the module config page.

So I added to the list. I then applied the configuration. I checked again and it gave me the same error. I took a look at the list again and found that all the changes that I made a minute or two before had been erased. I tried again with the same result.

I tried to edit resolv.conf manually, but the same exact thing happened.

That sort of thing can happen if another program is changing your resolv.conf file back to what it was — such as DHCP.

You need to prevent DHCP from overwriting your resolv.conf, or move to a statically configured IP address.

I solved the problem by uncommenting the following line in /etc/dhcp3/dhclient.conf #prepend domain-name-servers;


Sign in to leave a comment